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Migration Checklist: Blackboard to Canvas via K16 

The following post-migration information is for courses that are migrated from Blackboard to 
Canvas by the company K16. We tried to make the list as comprehensive as possible, so you 
may have to skip or ignore tools you do not use. 
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Terminology Changes 

Below is a quick list of important terminology changes for course tools. 

Blackboard Canvas 
Alignment Goal Outcomes 

Blog n/a – use Discussion 
Content Collection Files 

Course Content Modules 

Discussion Board Discussion 

Folder Module 
Grade Center, My Grades Grades 

Grade Center > Categories Assignments area > Assignment Groups 

Item Page 

Journal n/a – use Assignment 

Pool Question Bank (located in Quizzes area) 

Survey Survey (located in Quizzes area) 

Test Quiz 
Wiki n/a – try Collaboration 

Step 1: Take Notes of Potential Issues 

Issues or warnings from the K16 migration process will be listed on the “000-Migration 
Exception Log” page. Go to “Pages” > “View All Pages” to access the log (if there is one). 

The following table contains tools that will or will not migrate from Blackboard to Canvas. 

Migrates Fine Migrates But Needs Attention Will Not Migrate, Needs Readded 
Assignments 
Attachments 
Blank Page 
Calendar 
Categories 
Content Collection 
Course Menu Links 
Discussion Boards 
Due dates 
Files 
Images 
Items 
Kaltura 
Learning Modules 
Lesson Plans 
Mashups 
Module Pages 
Web Links 

Announcements 
Availability dates 
Blogs 
Content Areas 
Course Links 
Folders 
Glossaries 
Grade Center 
Groups 
Journals 
Rubrics 
Self and Peer Assessments 
Surveys 
Tests, Questions 
Wikis 

Adaptive Release 
Banner image 
Competency alignments 
Kaltura Video Quizzes 
LockDown Browser requirement 
Mark Reviewed status 
Publisher links 
Turnitin assignments 
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Step 2: Be on the Lookout 

As you’re updating your Canvas course, look for material that should be revised or removed, 
such as duplicates, media files, and accessibility issues. See the sections below for details. 

Replace Blackboard Terminology 

Revise any instructions, references, or links to Blackboard and Collaborate Ultra, along with 
Blackboard-specific verbiage (e.g., “New Thread” in discussions, My Grades, etc.). 

Delete the “Getting Started - Academic and Blackboard Support” continuity support materials 
(e.g., “Troubleshooting 101,” “How to use Blackboard Tools…”). That updated material is 
available through the “DMACC Student Resources and Support” link in the course Home Page 
template and in the “Help” menu. 

Cleanup Duplicates and Unnecessary Material 

Canvas courses have a size limit. We exceeded our storage limits in Blackboard and need to be 
judicious in managing course sizes. Check your course for duplicate/unnecessary material – if 
you/students aren’t actively using it each semester, now’s the time to get rid of it!  

Note: It’s important to keep file sizes as small as possible, not only to stay within course size 
limits, but also to make it easier for students to access/use that material.  

Pro Tip: You do not have to upload a file repeatedly to use it in more than one place in the 
course. Simply edit the page and click “Insert” > “Document” > “Course Documents,” then 
select the existing file. 

Cleanup Video/Audio 

Make sure you’re using Kaltura (or YouTube if you prefer) to store the audio/video that you 
created. You should not upload audio/video directly into the course for a variety of reasons 
(e.g., it won’t be accessible, it won’t stream, it’s likely a large file that gets duplicated). 

1. Kaltura – if you use the same video in multiple courses or sections, Kaltura lets you easily 
reuse the file instead of having multiple copies in multiple places. 

• Instructions for using Kaltura can be found by going to “Help” > “DMACC Instructor 
Resources and Support” > “Software” > “Kaltura.” 

• Note: Kaltura videos migrate in Pages. If the videos were added in Blackboard 
several years ago, you may want to re-embed them in your Canvas course so they 
use the latest player (use the “Apps”  button on the Rich Content Editor toolbar). 

2. Collaborate Ultra – remove any links to Collaborate sessions or recordings. 

• Kaltura Classroom – replaced Collaborate Ultra in May of 2023 and can be accessed 
from the “Kaltura Media Gallery” link in the course menu. Instructions can be found 
in “Help” > “DMACC Instructor Resources and Support” > “Software.” 
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3. PowerPoint with media – large media files in PowerPoint result in large files, which might 
be difficult for students to download/open due to internet speed, data limits, etc. 

• Audio – recorded on a slide in PowerPoint is not accessible. It would be best to 
record new lectures using Kaltura Capture and then edit the captions for accuracy. 

• Video – embedded on a slide likely lacks a written transcript or closed captions. Link 
to accessible videos on the web instead. 

• Images – can sometimes take up a lot of unnecessary space. Try compressing them 
to “On-screen” or “Email” resolution and deleting cropped areas (see Reduce the file 
size of your PowerPoint presentations for details – the steps are the same in Word). 

Check Accessibility 

Having accessible materials is not only required by law, but it’s also the right thing to do to 
ensure all students have the opportunity to learn. 

1. Ally – go to “Ally Course Accessibility Report” in the course menu to view the report and 
fix outstanding issues. All the Ally meters should be green (High to Perfect range). Visit the 
Ally Quick Start for Instructors webpage for more information. 

2. Accessibility Checker – when you’re adding or editing content, look for a notification alert 
on the “Accessibility Checker”  button below the Rich Content Editor textbox. Visit How 
do I use the Accessibility Checker in the Rich Content Editor as an instructor? for details. 

Here are a few other accessibility and usability issues to address. 

• Fonts – check for unnecessary formatting, such as multiple fonts, font sizes, and different 
colors for fonts, backgrounds, links, etc. Edit the content, select your text, and click the 
“Clear formatting” button   on the toolbar. 

• Titles – avoid duplicate titles. All titles should be short, descriptive, and unique. 
o Note: If there were duplicate names in Blackboard, K16 included the folder name in 

the subsequent titles (e.g., “Study Guide” and “Week 2 - Study Guide”; “Weekly 
Report” and “Week 3 - Weekly Report”). 

• Links – if you have hyperlinks, make sure the link text (i.e., what the student clicks on) is 
short, descriptive, and makes sense out of context (e.g., not “click here” or “this link”). Do 
not use the full web address as the link text unless it is short and easy to read/hear, such 
as “www.dmacc.edu.” 

• Explanations – add explanatory text to materials (e.g., files, links, videos) so students 
know how/when/why to use them. 

• Headings – if you have a lot of instructions, use headings to 
break up the material and make it easier to follow.  
o Select the text, click the “Blocks” (“Paragraph”) drop-

down menu, and choose “Heading 2” for the highest 
heading level (a sub-heading of that is “Heading 3”). 

https://support.microsoft.com/en-us/office/reduce-the-file-size-of-your-powerpoint-presentations-9548ffd4-d853-41e7-8e40-b606bca036b4
https://support.microsoft.com/en-us/office/reduce-the-file-size-of-your-powerpoint-presentations-9548ffd4-d853-41e7-8e40-b606bca036b4
https://help.blackboard.com/Ally/Ally_for_LMS/Instructor/Quick_Start
https://community.canvaslms.com/t5/Instructor-Guide/How-do-I-use-the-Accessibility-Checker-in-the-Rich-Content/ta-p/820
https://community.canvaslms.com/t5/Instructor-Guide/How-do-I-use-the-Accessibility-Checker-in-the-Rich-Content/ta-p/820
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Step 3: Cleanup the Learning Materials 

Keep the issues from Steps 1 & 2 in mind as you work through your course. This is also a good 
opportunity to refresh the course and make some of the changes you’ve been wanting to! 

Pro Tip: “Unpublish” everything in the course and then publish things after you’ve 
reviewed/modified them. That way you can easily see/know what still needs to be addressed. 

Content Availability  

Note: There isn’t a Date Management tool in Canvas since shifting dates is part of the 
copy/import process. 

Pro Tip: We recommend manually fixing the dates in the course so they’re ready for the 
upcoming semester (not waiting until Step 5 when you copy the course). 

1. Adaptive Release → Prerequisites – if you need to restrict access to modules based on 
certain criteria, you can use Prerequisites. Contact an instructional designer for help. 

a. Note: In most situations, prerequisites should not be added. 
2. Availability Dates – on learning materials (e.g., folders, items, files, etc.) do not migrate.  

a. Edit announcements to change their “Delay posting” date. 
b. To time-release a module, edit it and use the “Lock until” option. The unlock date is 

listed below the module. Students will be able to see the titles of published content. 
c. Note: Availability end dates do not exist on Announcements or Modules; content 

only has a start date so students can access learning materials from previous weeks. 
3. Mark Reviewed → Requirements > Mark as Done – if you want students to acknowledge 

that they accessed certain content, you can add a Requirement. For more information, 
visit How do I add requirements to a module? or the student guide on How do I mark a 
module item as done for a module requirement?. 

Module Organization 

Contents from Course Content, Syllabus, and Your Instructor (along with any extra content areas 
you had in your course menu) will be in the “Modules” area in Canvas courses. 

1. Organization – modules may need to be reorganized. Arrange modules chronologically 
from top to bottom (e.g., Getting Started, Week 1, etc.). Students and faculty can collapse 
modules to minimize what they see. 

a. Pro Tip: If a module has a lot of material, group 
things together with a “Text Header” (click the 
module’s “Add”  button > “Text Header”) and 
indentation (click the content’s “Manage”  button 
on the right > “Increase indent”). 

  

https://internal.dmacc.edu/online/pages/fcontact.aspx
https://community.canvaslms.com/t5/Instructor-Guide/How-do-I-add-requirements-to-a-module/ta-p/1131
https://community.canvaslms.com/t5/Student-Guide/How-do-I-mark-a-module-item-as-done-for-a-module-requirement/ta-p/311
https://community.canvaslms.com/t5/Student-Guide/How-do-I-mark-a-module-item-as-done-for-a-module-requirement/ta-p/311
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2. Cleanup – delete any unnecessary, extra modules. 
a. Syllabus module and contents – should be deleted since you’ll be using Simple 

Syllabus instead, beginning Fall 2023. 
b. Your Instructor module and contents – before deleting them, you may want to copy-

and-paste the info into the “Your Instructor” section of the course Home Page. 
c. Course Content module – if you had loose material in Course Content (not in a 

folder) it will be in the “Course Content” module. You should rename or delete it 
after moving the material into a more appropriate module. 

d. Blackboard folder descriptions – migrate as Pages in the module with the same title 
as the folder but with “Description” at the end. You might want to consolidate that 
information with an overview page if you have one. 

e. Nested folders – you can’t have modules inside of modules. If you had folders 
nested inside other folders, that material will be consolidated into one module. 
There will be a “Text Header” from the nested folder’s name and its contents will be 
indented below the Text Header. 

f. Past material – if you’re providing students with multiple copies of materials from 
the past several years, please keep only the most recent version.  

3. Instructor-only material – please remove material you no longer use regularly.  
a. If you need instructor-only material in the course, it’s best to consolidate that 

material and move it to a module that’s hidden from students, not scattered 
throughout the course. Publishing a module (making it available to students) will 
publish all the content in that module, which could result in the wrong material 
being visible to students. 

b. Pro Tip: We recommend keeping notes/instructions from past courses or optional 
assignments in a document on your computer (or network drive, cloud storage) 
instead of in your active course to keep the course/gradebook free of clutter. 

Types of Content 

1. ANNOUNCEMENTS – will have a generic user attached to them even after you edit them. 
If you want your name attached, you’ll need to create new announcements. 

a. The “Not Date Restricted” announcements will be in Canvas with a “Delay posting” 
date that matches when the announcement was posted in Blackboard. 

2. Attendance – can be recorded in Canvas. Visit How do I take roll call using the Attendance 
tool? for more information. 

a. To use the Attendance tool, go to “Settings” > “Navigation” and move it up below 
“Kaltura Media Gallery” so it’s visible to you. Students will not be able to see it in the 
course menu, but it must be enabled for you to access it. 

3. Blank Pages – migrate as Pages. 
4. Calendar – go to “Course Syllabus” and check the Course Schedule for old calendar events 

that need to be deleted. 
5. Course Links (from Blackboard’s Build Content > Course Link) – migrate as Pages. 

Depending on what you linked to, the page may be empty. Either delete it and add the 
material to the module, or edit the page and add a link to the appropriate material.  

https://community.canvaslms.com/t5/Instructor-Guide/How-do-I-take-roll-call-using-the-Attendance-tool/ta-p/995
https://community.canvaslms.com/t5/Instructor-Guide/How-do-I-take-roll-call-using-the-Attendance-tool/ta-p/995
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6. Files area – contains all the files you were using in Blackboard (from Content Collection).  
a. Pro Tip: To replace a file with an updated version that has the same filename, go to 

“Files,” click “Upload,” select the file, and click “Open.” In the pop-up warning 
message about the file already existing, click the “Replace” button. 

7. Files – (from Build Content > File) migrate as Files in the module, but you should attach 
them to a page instead so you can explain how/when/why students should use the file. 

a. Pro Tip: Consolidate multiple, separate files in the module into one page to 
streamline the course. 

8. Glossaries – migrate as Pages using the HTML code from Blackboard, which is not 
accessible. Please contact Kayleen Grage (kmgrage@dmacc.edu) for assistance. 
Alternatively, you could export the glossary from Blackboard and share that spreadsheet 
with your students in Canvas. 

9. Images (from Blackboard’s Build Content > Image) – migrate as Pages. 
10. Lesson Plans – migrate as Text Headers in the module. The description will not migrate. 
11. Learning Modules – migrate as Modules in Canvas. Like folders, the description from the 

module migrates as a Page. 
a. Module Pages – migrate as Pages. 

12. Mashups for Flickr, Kaltura, Slideshare, YouTube – migrate as Pages. 
a. Note: See Cleanup Video/Audio in Step 2 for details about Kaltura mashups. 

13. Pages – Pro Tip: If you have weekly activities lists (for reading assignments and other 
learning activities), add them to students’ “To Do” list! Edit the page, select the “Add to 
student to-do” option, and set the date (such as a day or two into the week). 

14. PUBLISHER MATERIAL – needs to be relinked in Canvas since the integration is different. 
Visit our Publisher Integration Guide (PDF) for more information. 

15. Web Links – migrate as External URLs in the module. However, if there was description 
text in Blackboard, they migrate as Pages with the description and link. 

a. Pro Tip: Consolidate multiple, separate External URLs in the module into one page to 
streamline the course. 

Step 4: Cleanup the Graded Activities 

The “Assignments” area contains all graded activities, not just the Assignment tool. 

Settings and Rubrics 

1. ASSIGNMENT GROUPS (in Assignments area) – should match the categories you had in 
Blackboard, but you will want to double-check that everything is in the correct group. 

a. Remove any extra Assignment Groups. Each one will have a total column in Grades, 
so leave only the ones you are using. 

b. If you weigh grades, you will need to configure 
that by clicking the “Assignment Settings” 
button (three dots) in the upper-right corner and 
choosing “Assignment Groups Weight.” 

mailto:kmgrage@dmacc.edu
https://bbmedia.dmacc.edu/bbTraining/canvas/Publisher_Integration_Guide.pdf
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c. Visit How do I weight the final course grade based on assignment groups? for details. 
d. Note: Assignment Group totals are proportional calculations (points earned divided 

into points possible). If you used equally weighted grades in Blackboard (i.e., 
category average), you’ll need to use consistent assignment point values instead. 
Contact an instructional designer for help. 

2. Availability Dates – on graded activities migrate and can be added/adjusted, but we do 
not recommend using them. If an assignment is in a module that’s locked until a certain 
date, students will not be able to access it until the module is available.  

a. Pro Tip: Instead of adding availability end dates on graded activities, we recommend 
setting a Late Policy (see Grades below). 

3. DUE DATES – are required for all graded activities. Visit the DMACC Gradebook 
Expectations for more information. 

4. Grades area – the “Default Order” view is based on the order in the Assignments area. 
a. Grading Schemas do not migrate; select from pre-existing schemes or add your own 

in the course “Settings.” Visit the DMACC Gradebook Expectations for details. 
b. Total columns for each Assignment Group will automatically be displayed in Grades, 

visible to you and students (see Assignment Groups above). 
c. To set a Late Policy, click the “Gradebook Settings”  icon in the upper-right corner. 

Visit How do I apply a Late Submission policy in the Gradebook? for details. 
5. RUBRICS – migrate but may need to be revised or replaced (or deleted if unused). 

a. Note: Rubrics can only be points-based (point value or point range), not percentage-
based. You also cannot have negative values. 

b. Remove any extra, unnecessary cells (e.g., multiple “0” cells in the row because 
Blackboard required the same number of columns for each row). 

c. Only one rubric can be attached to a graded activity in Canvas, so you may need to 
add an ungraded assignment for DMACC/departmental assessment scoring. 

d. Pro Tip: If the rubric is for DMACC assessment (i.e., ELO or program), it might already 
be in Canvas. In which case, delete the rubric that was migrated because it might be 
outdated or missing outcomes. Then find and add the pre-existing rubric. 

Assignments and Discussions 

1. ASSIGNMENTS – migrate as Assignments with the “Submission Type” of “Text Entry” and 
“File Uploads,” which you may want to adjust. 

a. Manually created gradebook columns from Blackboard migrate as Assignments 
with a “Submission Type” of “No Submission.” Edit them and provide a description 
or explanation for students. You’ll also need to add them to the appropriate module 
and make sure they have a due date. 

• If the column had a “Primary Display” of “Text,” you may need to delete the 
migrated assignment. That type of display is not possible in Canvas. You may 
want to use the Notes column to record instructor notes (visit How do I use 
the Notes column in the Gradebook?). 

b. SafeAssign is a Blackboard-only tool; for plagiarism detection in Canvas, you will 
need to use a Turnitin assignment instead (see Turnitin Assignments below). 

https://community.canvaslms.com/t5/Instructor-Guide/How-do-I-weight-the-final-course-grade-based-on-assignment/ta-p/746
https://internal.dmacc.edu/online/pages/fcontact.aspx
https://internal.dmacc.edu/online/Pages/gradebook-expectations.aspx
https://internal.dmacc.edu/online/Pages/gradebook-expectations.aspx
https://internal.dmacc.edu/online/Pages/gradebook-expectations.aspx
https://community.canvaslms.com/t5/Instructor-Guide/How-do-I-apply-a-Late-Submission-policy-in-the-Gradebook/ta-p/965
https://community.canvaslms.com/t5/Instructor-Guide/How-do-I-use-the-Notes-column-in-the-Gradebook/ta-p/940
https://community.canvaslms.com/t5/Instructor-Guide/How-do-I-use-the-Notes-column-in-the-Gradebook/ta-p/940
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2. Blogs – migrate as Discussions, so instructions may need to be revised.  
a. The blog setting for "Allow Anonymous Comments" is not possible in discussions. 

3. DISCUSSIONS – threads cannot be migrated since they are tied to users, not courses. 
a. Instructions from Course Content and/or the discussion settings were migrated. K16 

uses a 90% match on discussion instructions. If your instructions in Course Content 
differed from those in the actual discussion settings by more than 90%, both sets of 
instructions were migrated. 

b. Check instructions for terminology changes.  

• Students don’t create threads; they reply to the topic/instructions.  

• There aren’t subject lines or a message area. 

• The “Reply with Quote” option doesn’t exist in Canvas. 
4. Journals – migrate as Assignments with unlimited attempts. Titles and instructions may 

need to be revised. 
a. If the journal was ungraded, the Canvas assignment will be set to zero points. 
b. If you only want students to submit text, edit the assignment and deselect the “File 

Uploads” Submission Type. 
5. Kaltura Video Quizzes – migrate as Pages. They need to be recreated as Assignments (for 

“Submission Type” use “External Tool” > “Find” > “Kaltura Quiz”). 
6. PUBLISHER MATERIALS – need to be relinked in Canvas since the integration is different. 

Visit our Publisher Integration Guide (PDF) for more information. 
7. Self and Peer Assessments – migrate as normal Assignments. Assessment questions and 

evaluation dates do not migrate. 
a. Edit the assignment and select “Require Peer Reviews.” Visit How do I use peer 

review assignments in a course? for more information. 
b. Revise the instructions, add the assessment questions from Blackboard, and add the 

due date. 
8. Turnitin Assignments – need to be recreated in Canvas since the integration is different. 

Information and detailed instructions can be found on Turnitin's Canvas LTI 1.3 Instructor 
website. After you’ve created the Turnitin assignment, don’t forget to add it to the 
appropriate module. 

9. Wikis – migrate as Pages that can be edited by students, so titles and instructions may 
need revisions (visit How do I edit a page in a course? and How do I edit a course page as a 
student?). Pages cannot be graded so you may need to add an assignment for grading. 

a. Alternatively, you may want to try Collaborations (visit How do I use the 
Collaborations Index Page? for more information). 

Quizzes and Surveys 

Quizzes (Tests from Blackboard) and Surveys can be accessed from Quizzes or Modules. Quizzes 
and Graded Surveys can also be accessed from the Assignments area. 

The default quiz type is Classic Quizzes. For information on the difference between Canvas 
Classic Quizzes and New Quizzes, visit Canvas New Quizzes Feature Comparison. 

https://bbmedia.dmacc.edu/bbTraining/canvas/Publisher_Integration_Guide.pdf
https://community.canvaslms.com/t5/Instructor-Guide/How-do-I-use-peer-review-assignments-in-a-course/ta-p/697
https://community.canvaslms.com/t5/Instructor-Guide/How-do-I-use-peer-review-assignments-in-a-course/ta-p/697
https://help.turnitin.com/feedback-studio/canvas/lti13/instructor/instructor-category.htm
https://community.canvaslms.com/t5/Instructor-Guide/How-do-I-edit-a-page-in-a-course/ta-p/791
https://community.canvaslms.com/t5/Student-Guide/How-do-I-edit-a-course-page-as-a-student/ta-p/479
https://community.canvaslms.com/t5/Student-Guide/How-do-I-edit-a-course-page-as-a-student/ta-p/479
https://community.canvaslms.com/t5/Instructor-Guide/How-do-I-use-the-Collaborations-Index-Page/ta-p/922
https://community.canvaslms.com/t5/Instructor-Guide/How-do-I-use-the-Collaborations-Index-Page/ta-p/922
https://docs.google.com/document/d/11nSS2EP0UpSM6dcuEFnoF-hC6lyqWbE9JSHELNmfG2A/edit
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1. Questions – should be checked for accuracy. Edit the quiz/survey, switch to the 
“Questions” tab, and click the “Edit this Question”  pencil icon on the right. 

a. Check the point value and images.  

• Images from the question text will migrate. Images in answer options may 
not migrate. Images in feedback/comments will not migrate. 

• Questions cannot be marked as extra credit in Canvas. You may want to 
make them worth 0 points and then manually grade and award points. 

• If you had an essay answer in Blackboard, you may want to copy-and-paste 
that into the question’s “general comments” area. 

• If you allowed partial credit for some questions in Blackboard, you may want 
to switch to New Quizzes. 

b. If the questions weren’t pulling from a pool, they will be placed in an "Unfiled 
Questions" question bank. You may want to move those into separate banks. 

c. If you want questions randomized, create a “New Question Group,” then drag-and-
drop the questions into the group or add them from a Question Bank. Visit How do I 
create a quiz with a question group to randomize quiz questions? for details. 

d. Competency (Outcome) alignments need to be readded. Visit How do I align an 
outcome to a quiz question in New Quizzes? for more information or contact the 
Assessment Department. 

e. Question Types – several question types don’t exist in Canvas Classic Quizzes and 
were either not migrated or migrated as a different type. 

• Calculated Formula → Fill In the Blank – needs to be switched to a “Formula 
Question” and revised (particularly the answer, which may be incorrect). 

• Calculated Numeric → Numerical Answer 

• Either/Or → True/False – may need to be reworded if you had it set to 
display as agree/disagree, right/wrong, or yes/no in Blackboard. 

• Essay – rubrics cannot be added to essay question. Visit How do I add a rubric 
to a quiz? or consider using an assignment instead. 

• File Response → File Upload Question  

• Fill in the Blank – does not have “Contains” or “Pattern Match” answer 
options and answers are not case sensitive. You may want to switch to New 
Quizzes for more refined answer options. 

• Hot Spot – does not migrate. Revise the question and add it. (Note: New 
Quizzes allow Hot Spots but they are not accessible and should not be used.) 

• Jumbled Sentence → Multiple Dropdowns 

• Matching – answer pairs cannot have images. You may want to include the 
images in the question text instead. 

• Opinion Scale/Likert → Multiple Choice 

• Ordering → Matching 

• Quiz Bowl – does not migrate. Revise the question and add it. 

• Question Set → Question Group 

• Random Block → Question Group 

• Short Answer → Essay Question 

https://community.canvaslms.com/t5/Instructor-Guide/How-do-I-create-a-quiz-with-a-question-group-to-randomize-quiz/ta-p/1032
https://community.canvaslms.com/t5/Instructor-Guide/How-do-I-create-a-quiz-with-a-question-group-to-randomize-quiz/ta-p/1032
https://community.canvaslms.com/t5/Instructor-Guide/How-do-I-align-an-outcome-to-a-quiz-question-in-New-Quizzes/ta-p/778
https://community.canvaslms.com/t5/Instructor-Guide/How-do-I-align-an-outcome-to-a-quiz-question-in-New-Quizzes/ta-p/778
https://community.canvaslms.com/t5/Instructor-Guide/How-do-I-add-a-rubric-to-a-quiz/ta-p/1009
https://community.canvaslms.com/t5/Instructor-Guide/How-do-I-add-a-rubric-to-a-quiz/ta-p/1009
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• Note: Not included above are the standard questions that are the same in 
both systems, such as Multiple Choice and True/False. 

2. Settings – may need to be adjusted since options differ in Blackboard and Canvas. 
a. Descriptions/instructions – from Course Content and/or the test settings were 

migrated. K16 uses an 80% match on test instructions. If your description in Course 
Content differed from the description or instructions in the actual test settings by 
more than 80%, both/all three were migrated. 

b. “Randomize Questions” does not migrate (see Questions above).  
c. If you want question answers randomized, select the “Shuffle Answers” option. It 

applies to all quiz questions and cannot be selected on a question-by-question basis. 
d. You may want to adjust the options for displaying results to students. 
e. If you used the setting in Blackboard for “Do not allow students to start the Test if 

the due date has passed,” you may want to add an “Available Until” date or set up a 
Late Assignment policy (see Grades above in Settings and Rubrics). 

f. Visit What options can I set in a quiz? for more information. 
3. Surveys – migrate as Ungraded Surveys. 

a. Note: Surveys are not anonymous by default. If your survey should be anonymous, 
edit it and select the “Keep Submissions Anonymous” option. 

b. If you award points for completing the survey, change the “Quiz Type” to “Graded 
Survey” and enter the “Score” students should automatically receive upon 
submission. If it should be extra credit, type “0” for the “Score” and then award the 
correct number of points after students have submitted it.  

4. LockDown Browser – will need to be added again in Canvas if your quiz requires it. 
a. Edit the quiz and remove the code in the “Require an access code” textbox since 

that was the password LockDown Browser used in Blackboard.  
b. Go to “Settings” > “Navigation” and move “LockDown Browser” up below “Kaltura 

Media Gallery” so it’s visible to you. Students will not be able to see it in the course 
menu, but it must be enabled for you to access it. 

c. If you see an error message after enabling LockDown Browser on a quiz, click the 
“Fix It” button. 

Groups 

Groups and Group Sets from Blackboard can be accessed from the People area. 

1. If you had multiple Group Sets in Blackboard, it may be easier just to make all new Group 
Sets in Canvas and delete the migrated sets/groups. 

2. Links in Course Content to the group area do not migrate. Consider using a Page or “Not 
Graded” Assignment if you need to provide reminders. 

3. Group assignments migrate as normal assignments. You will need to edit the assignment 
and reassign the Group Set (select “This is a Group Assignment”). 

4. Group discussion boards are in Discussions, but you will need to delete the duplicates 
(you only need one of them, not one per group).  

https://community.canvaslms.com/t5/Instructor-Guide/What-options-can-I-set-in-a-quiz/ta-p/683
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a. Graded group discussions migrate without Group Sets or grading enabled. Edit the 
discussion, select “Graded” and “This is a Group Discussion.” Then select the 
appropriate Group Set. 

b. Ungraded group discussions can be created in the individual group areas (i.e., 
meant for the group members to discuss amongst themselves about a project). 

5. Depending on the Blackboard Group Set settings, you may need to delete the migrated 
material for group wikis, blogs, and/or journals that were automatically created with the 
groups in Blackboard. 

Step 5: Give it a Once- (Twice-, Thrice-) Over  

Go through the entire course to make sure everything is accurate and ready for students. 

1. Publish status – double-check Pages, Assignments, and Modules to make sure content is 
published . If it is not published, students will not be able to access it. Also check for 
content that should not be published, such as instructor-only materials. 

2. Due Dates and Modules – go to Assignments to make sure everything has a due date and 
is in a module – both will be listed below the title.  

 
a. If you use weighted grades, make sure things are in the correct Assignment Group. 
b. Click the “Assignment Settings” button (three dots) in the upper-right corner and 

choose “Edit Assignment Dates” to view and adjust all the due dates. 
3. Accessibility and Usability – check accessibility from the “Ally Course Accessibility Report” 

in the course menu. Below are some aspects to check for usability (see Check Accessibility 
in Step 2 for more tips). 

a. You can go to “Settings” > “Validate Links in Content” to make sure there aren’t 
broken links to Canvas content. Visit How do I validate links in a course? for more 
information. Also check your material for broken links to external websites/videos. 

b. Use the “Student View” tool in the upper-right corner to get a student’s perspective. 
(Is it obvious what they should do each week? Are instructions clear and detailed?) 

4. Course banner image → Course Card – if you had a banner image that displayed in 
Announcements in Blackboard, you can add it to the course card that is visible in the 
Canvas Dashboard. Visit How do I add an image to a course card in the Dashboard? for 
more information. 
a. Pro Tip: If you don’t already have the image on your computer, download it from 

Blackboard (right-click on the image and choose “Save Image As”). 

  

https://community.canvaslms.com/t5/Instructor-Guide/How-do-I-validate-links-in-a-course/ta-p/1001
https://community.canvaslms.com/t5/Instructor-Guide/How-do-I-add-an-image-to-a-course-card-in-the-Dashboard/ta-p/624
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Step 6: Copy the Course 

After your course is ready, you can copy it to your course shell for the upcoming semester. If 
you want to merge your sections, make sure you request the merge before copying.  

In Blackboard you could only copy from the course that has the content. However, in Canvas 
you can also import another course from within the new course where you want it – this is the 
process we recommend so you can make sure it’s empty before copying in another course. 

1. Go into the new, empty course shell for the upcoming semester. 
2. From your course “Home” page, click the “Import Existing Content” button on the right 

(or from “Settings” click “Import Course Content”). 
3. For the “Content Type,” choose “Copy a Canvas Course.” 
4. Click the “Select a course” drop-down menu or use the search box to find a specific CRN. 
5. Select the “All content” option. 

a. Note: Skip the “Adjust event and due dates” option if you’ve already updated the 
dates in the course as recommended. Otherwise visit How do I adjust events and due 
dates in a course import? for more information. 

6. Click the “Import” button.  
7. If you want to use the Home page from the course that was copied 

in, go to “Pages” and click the “View All Pages” button at the top. 
Find the “Home Page-2” page, click the three dots to the right, and 
choose “Use as Front Page.” 

You can also visit Canvas guides on How do I copy content from another Canvas course using the 
Course Import tool? or How do I copy a Canvas course into a new course shell?. 

Note: If you copy the wrong course, please contact an instructional designer right away. They 
can clear out your Canvas course so you can start over. 

 

Need Help? 

Contact an instructional designer in Distance Learning or access the following resources. 

• Visit the Start-of-Term Guide (PDF) to make sure your course is ready to go for students. 

• Follow the Migration Checklist: Export from Blackboard to Canvas (PDF) to migrate a 
course on your own. 

• For accessibility information, go to “Help” > “DMACC Instructor Resources and Support” > 
“Expectations” > “Accessibility.” 

• For help using Canvas, you can use the Growing with Canvas modules in the Instructor 
Training and Resources course or the Canvas Instructor Guide Table of Contents. 

• Distance Learning offers a variety of training sessions online on a regular basis. Visit the 
Training Sessions Calendar for a list of upcoming events. 

https://internal.dmacc.edu/online/Pages/bbforms.aspx
https://community.canvaslms.com/t5/Instructor-Guide/How-do-I-adjust-events-and-due-dates-in-a-course-import/ta-p/1090
https://community.canvaslms.com/t5/Instructor-Guide/How-do-I-adjust-events-and-due-dates-in-a-course-import/ta-p/1090
https://community.canvaslms.com/t5/Instructor-Guide/How-do-I-copy-content-from-another-Canvas-course-using-the/ta-p/1012
https://community.canvaslms.com/t5/Instructor-Guide/How-do-I-copy-content-from-another-Canvas-course-using-the/ta-p/1012
https://community.canvaslms.com/t5/Instructor-Guide/How-do-I-copy-a-Canvas-course-into-a-new-course-shell/ta-p/712
https://internal.dmacc.edu/online/pages/fcontact.aspx
https://internal.dmacc.edu/online/pages/fcontact.aspx
https://bbmedia.dmacc.edu/bbTraining/Shared%20Documents/TermStartGuide_Canvas.pdf
https://bbmedia.dmacc.edu/bbTraining/canvas/Migration-Checklist_Blackboard-to-Canvas.pdf
https://community.canvaslms.com/t5/Instructor-Guide/tkb-p/Instructor
https://internal.dmacc.edu/online/Pages/training.aspx
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